Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 12, 2025 - 08:00 EST
Scheduled
We will be performing our regular monthly maintenance on all Mindful Callback services February 12th - February 14th. No downtime or caller impact is expected.
Posted Feb 05, 2025 - 14:44 EST
This scheduled maintenance affected: Management Portal, Mindful Insights, Mindful API, Mindful Scheduler Widgets, Notifications, Datastore, and Mindful Callback Voice - Americas, US East.