Mindful Insights - service degradation

Incident Report for Mindful for Government

Resolved

This incident has been resolved.

A formal RCA will be submitted for completion and available for clients upon request.
Posted Oct 30, 2025 - 15:44 EDT

Identified

An issue with Mindful Insights has been identified. The engineering team is gathering further information and is working on a resolution.

Issue: Call number data not matching between Call Details and Insights
Posted Oct 29, 2025 - 16:00 EDT
This incident affected: Mindful Insights.