Mindful Insights - performance degradation

Incident Report for Mindful for Government

Resolved

Our health metrics indicate that all Mindful services are resolved and in a healthy state. If you should experience any issues or have additional questions, please reach out and submit a case via the support channel.
Posted Oct 21, 2025 - 12:26 EDT

Monitoring

Our 3rd party cloud provider has taken action to mitigate identified issues. While they continue to monitor services, our health metrics indicate that Scheduler Widgets and our API endpoints are now fully recovered and operational. Mindful Insights continues to experience service degradation as processing of data has been delayed. We will continue to monitor and provide updates as necessary to ensure recovery of all Mindful services.
Posted Oct 20, 2025 - 20:33 EDT

Update

Our 3rd party cloud provider has observed signs of their services returning to a healthy state following latest mitigation actions. Mindful components such as APIs, Scheduler Widgets and Insights continue to experience service degradation as recovery steps take place. We will continue to monitor the situation and provide updates as necessary.
Posted Oct 20, 2025 - 14:36 EDT

Investigating

Our 3rd party cloud provider is experiencing service degradation which is causing Mindful's historical reporting to be inaccurate. There is no data loss at this time, however, the processing of the data has been delayed. Historical reports in Mindful Insights are currently being impacted. We will continue to monitor the situation and provide updates as necessary.
Posted Oct 20, 2025 - 09:54 EDT
This incident affected: Mindful Insights, Mindful API, and Mindful Scheduler Widgets.