Mindful Gov - Callback Failures

Incident Report for Mindful for Government

Resolved

This incident has been resolved. The development team has validated that calls are processing as expected via backend verifications. If there are further issues identified, please reach out to the Mindful Support team.
Posted Mar 13, 2025 - 16:13 EDT

Monitoring

A fix has been implemented and the incident is mitigated as of 3:19p ET. Calls are now processing as expected.
The team will continue further investigation to determine RCA.
Posted Mar 13, 2025 - 15:32 EDT

Update

We are continuing to investigate this issue.
Posted Mar 13, 2025 - 15:07 EDT

Investigating

We are currently investigating an issue causing callback failures on the Mindful Gov platform. The development team is actively engaged and the issue is escalated
Posted Mar 13, 2025 - 15:06 EDT
This incident affected: Mindful Callback Voice - Americas, US East.